From The Sims Wiki, a collaborative database for The Sims series
Jump to navigation Jump to search

This is a page for discussing improvements to Glitches

Talk pages are used to discuss changes or improvements to the article or page only. Please use the game discussions forum for game discussions, help desk for game questions, or the off-topic forum for general conversations. Real-time conversation about The Sims (as well as off-topic discussions) can also be found on The Sims Wiki's IRC Channel or Discord server.

1 2

Glitch[edit source]

On sims 3 tried to talk to one of the neighbourhood sims but nothing came up. Clicking on other objects works fine it's just that one sim. I have the Showtime and Pets expansion packs86.27.119.141 (talk) 22:14, November 19, 2014 (UTC)

TS3 for PS3[edit source]

Okay, so I just bought the sims 3 for ps3, and played it for several days. I got my sim couple to try for baby and I heard the chime or lulliby so I assumed she got pregnant. Then the next day she threw up, multiple times, as I expected she would..... But the issue was that after that, it's almost like she never got pregnant. I never got the baby bump, nor she had the moodlets you're suppose to have. I tried for baby multiple times and I never got the music chime/lulliby ever again. It's been a week in sims days, and no baby bumps. I'm getting a little aggravated with this problem. I wanted to see if there was anyway to fix this?—Preceding unsigned comment added by (talkcontribs) 06:03, November 20, 2014‎ (UTC) - Please sign your comments with ~~~~

Sims 2 Triple Deluxe stuck in bed[edit source]

On the sims 2, I have two sims named Hobo Troyarous and Kana Troyarous. Kana is pregnant. They got married after Hobo's old wife died. I had them sleep in a double bed. At morning, I tried to make them get out of bed, and they wouldn't. The only thing I could do besides quitting without saving was move my sims. Eh. I was going to have them move anyways. I had them move, and when they slept, it happened again! That time, I quit without saving. I won't use a double bed next time, but why is this happening? (talk) 13:37, November 27, 2014 (UTC)

Cannot create a file so if u know anything about it email me at[edit source]

The games will not let you create a file. It will say cannot create a sufficient file not enough sufficient memory. I have tried everything and if u know anything email me at Plz help I haven't been able to go onto it —Preceding unsigned comment added by (talkcontribs) 01:08, December 10, 2014‎ (UTC) - Please sign your comments with ~~~~

Unfortunately I don't send emails for cases like these, especially because someone else might want to know the answer and it's only fair if it's publicly available. But first, we need to know what game are you referring to? The Sims 1? 2? 3? 4? --I am k6ka Talk to me! See what I have done 01:11, December 10, 2014 (UTC)

Sims 3 glitch[edit source]

Do you know when on the side you have little pictures of your Sims. I have 6 (or 5 I cant remember) Sims and my first and last Sims picture thingy is still there but my other Sims pictures have disappeared and have been replaced by green squares. When I try to switch sim (by clicking on another little picture thing) nothing happens and since my other Sims were in my house I tried to get the Sims I could still use to interact with my frozen Sims but when I clicked on them nothing happened. After I did that a couple times I saved and quit and went on my Sims game again but instead what happened earlier all of my little sim picture thingy's completely disappeared and I couldn't even switch between the 2 Sims I could use earlier I could only use 1. Does anyone know how to fix this glitch without deleting the game or to stop using cheats? Because I love using cheats and it took me ages to get all my Sims skill level so high for so many things.—Preceding unsigned comment added by (talkcontribs) 16:37, December 10, 2014 (UTC) - Please sign your comments with ~~~~

In my sims3 game I have the expansions generations, university life, seasons, and world adventures. Then, I have thw worlds hidden springs, monte vista, and riverview. I installed all of them yesterday and the same glitch was happening. All the plants disappear in map view and if you get too far away in "household mode". Has anyone experienced this? If so PLEASE help me out. this glitch annoys me to no end. Thanks. (talk) 20:12, December 27, 2014 (UTC)

Sims 3 University Life[edit source]

My sim keeps glitching when talking to his romantic interest in University Life. When I try to get them to go to the next level, the game acts as if nothing was requested. And when I went into the relationship tab, all of his family members disappeared, and he can't call anyone. And when he would go to do an introduction, he goes up to the sim, and then the command is cancelled.

When he would have dinner with one of his roommates, a reset would happen without my authorization, and he would be outside the house with that roommate.

I figured this was just that portion of the game so I wasn't going to worry about it, until it was time for the sim to go back home from University, and now I can't seem to get the game to load in the main town. The loading bar is stuck with just a small bit left to be loaded, and the screens keep changing behind it (find the such n such object related to such n such patch).

Does anyone have any idea on how to fix this? (talk) 14:52, February 15, 2015 (UTC)

The Sims 3: Can't go to work      [edit source]

Okay so, for some strange reason my sim won't go to work. No matter how many times I press the "Go to work" button the actions go away all at the same time. This has happened to two of my Sim familys in totally different worlds. I've tried multiple times to reset the sim and quit their job them employ them in that field again but nothing changes. This has happened to me once and I was forced to have my sim quit their job to avoid bad moodlets ect. and is now this is happening to me again, and my sim NEEDS this job. Please help D: (talk) 17:40, April 4, 2015 (UTC)

In order to help you, we need to know what game you are experiencing this issue in. The Sims, The Sims 2, The Sims 3 or The Sims 4? --I am k6ka Talk to me! See what I have done 19:02, April 4, 2015 (UTC)
The unregistered user does not mention walking/driving to work. Coupled with that, the mention of moodlets indicates that this is The Sims 4. Ѧüя◎ґ (talk) 02:41, April 5, 2015 (UTC)

On Sims 3 all of my sims relationships disappeared. Like she does know anyone in the household anymore and when I get them to talk to each other its like they are friends, but none of the relationships show up. (talk) 14:48, May 15, 2015 (UTC)PotatoMushroom

Stuck in the Foundation! Sims 3[edit source]

Hello. My sim was about to come home from the hospital, and went in a taxi cab. As usual, the taxi cab drove my sim back to the house... I got home, and my sim went inside. They walked straight into the kitchen, through the entry hall, and dissapeared... into the foundation (?). I couldn't get out, even by trying to break the foundation and building stairs up to my house. So I gave up, and quit. I tried three more times, and the same thing happened. On my second last try, I tried quitting the action of going home in the taxi cab. It made that clicking noise that happens when you cancel an action... but no red X came up. I tried everything, from a teleporter to building a ladder. Still, nothing works. My world is my best one, living in the Goth's Manor with 150,000 simoleons as my household funds. I can't lose all of my great progress... Help!

P.S. My sim just had twins... and now one of them is stuck in the foundation with my sim! x( (talk) 00:41, June 11, 2015 (UTC)Kennedy I. 

Open the Cheat console with Ctrl+Shift+C, type in moveObjects on, and then move your Sim. Make sure to type in moveObjects off after fixing. If you don't, weird stuff happens. If this doesn't work, please take a screenshot of the situation.

And also, about the taxi-action-not-ending thing, read the advice I gave below if it doesn't stop after the above is fixed. The Minish LAN (talk) 09:34, June 14, 2015 (UTC)

Teach to Talk glitch[edit source]

When I was teaching my toddler to talk, another of my toddlers cried because their bladder had gone down. So I tried to cancel the action, but she didn't move. At all. Not even any animations, just stopped. Anyway, like the idiot I am, I saved. I suck. Is there any way to fix this?

P.S: The Sims 3, Base Game, No Stuff/Expansion Packs bought whatsoever, Week 6, Day 2, 3 triplets. —Preceding unsigned comment added by (talkcontribs) 08:58, June 14, 2015‎ (UTC) - Please sign your comments with ~~~~

There is a way to fix this, even after saving. Open the console with Ctrl+Shift+C, and type in resetSim <FULL Sim name>! Hope this helps!

P.S: This glitch definitely needs to be added to the list. The Minish LAN (talk) 09:12, June 14, 2015 (UTC)

Glitch?[edit source]

I 'replaced' my house but only 1 room changed and it wasn't what I got. Is there any way to undo it and put my house back to normal and give back my funds.??(Friday July 10) —Preceding unsigned comment added by (talkcontribs) 21:40, July 10, 2015‎ (UTC) - Please sign your comments with ~~~~

Glitch[edit source]

On the left side where I have my sims Icons (I have 6 currently), whenever I try switching between the the panel on the bottom right (where it shows the relationships, jobs, mood meter, ETC.) it has a certain sims set on different tabs and on the mood meter. plz help.

(I also have the University and Late night expansion pack if that means anything) —Preceding unsigned comment added by (talkcontribs) 14:39, August 20, 2015‎ (UTC) - Please sign your comments with ~~~~

Sims 3 Glitch?[edit source]

Just today when I loaded up my game it was fine, but i enabled cheats went to the menu and then back to the game. (I have a bit of CC, Supernatural, Seasons, Showtime, and Into The Future in the game and i don't know if any of these contributed) The glitch is just a minor annoyance. What happens is when I go up a level/floor on a lot, a telaporter noise plays. I haven't compared them yet but it might be the Llama's noise. I hope it goes a way next time I play. (talk) 14:34, August 24, 2015 (UTC)

Sims 3 Caught By Police Glitch[edit source]

This glitch is horrible and annoying! I have a job as a thief, a cutpurse. Recently I got caught by the police and then I wait, so then my sim disappears and I can't do anything, I can't view my sim, can't switch out of the inventory, can't do anything! And the moods are stuck and everything. I have to go back to my last save but then I know it's going to happen again because I still have that job. Is there any way to fix it, because I have searched everywhere I could and found nobody else having this problem? I have Dragon Valley Gold (with an unofficial patch to fix the dragon hatching glitch), and The Duke of Bows Renaissance Faire.—Preceding unsigned comment added by (talkcontribs) (UTC) - Please sign your comments with ~~~~

Annoying Sims 3 glitch[edit source]

So I had my sim take her toddler out and when they got home she put her child down and now every couple of seconds she freezes and looks like she's holding a toddler. It's really annoying and I can't figure out how to make it stop. I've tried closing and reopening the game but it didn't work. She does it all the time! Even when she's holding the kid!

There's also a glitch that is much less annoying and doesn't really bother me as much. My male werewolves' skin is pitch black when they're in their werewolf form. They look normal in their human form. And it only happens to my male werewolves. —Preceding unsigned comment added by (talk) 03:22, April 22, 2016 (UTC) - Please sign your comments with ~~~~

More Sims 1 Glitches[edit source]

There's a SUPER annoying game-breaking glitch where dogs (not cats, only dogs) interacting with any other sims (or pets) will leave behind PetDogSocial objects which can clog up the memory on a lot to the point where it becomes unusable -- both residential and community lots. Residential lots affected will slow to a crawl (literally a frame per second) in live mode, although build/buy modes work fine. Community lots affected will no longer load, after a certain point. The loading splash will show up and the music will eventually fade out, which indicates that the lot itself is actually loading, ESPCIALLY since I can also hear lot sounds (like NPCs talking idly or those funky floor fountains that shoot water into the air), but the splash never disappears. The only way to get out of it is to quit the game, which sends your sim back to their lot. I'm not actually 100% certain that the community lot not loading glitch is related to the dogs, but I can't fathom what else it'd be. Bulldozing will not fix this glitch, I haven't yet tested replacing the lot through the program files. There's a hacked CC object (a litterbox or something) that fixes it, but is no longer available online (T~T). One non-game-breaking glitch is the "No actions available" bug, where a sim will suddenly and for seemingly no reason become un-interactable-with. This can be fixed by getting the affected sim to sit on the red pinstriped loveseat. There are probably more but I can't think of them right now. I realize this is a huge info dump but it's better than me trying to shove all this info into the wiki myself. GL :) Katgirl28888 (talk) 09:55, May 18, 2016 (UTC)

Sims 4 glitches?[edit source]

Bugs in my game

--Rizkirafu (talk) 02:32, July 26, 2016 (UTC)

There is a glitch[edit source]

My name is samuel savage and there is a realy severe glitch. I play the xbox 360 version. Everytime i press save and continue it saves but after i return to the world i notice that my sim is floating in mid air. The game then starts to act strange and then i notice the need bars going down faster than it should be then my sim would die. Is there anyone who knows what is happening? —Preceding unsigned comment added by Samuel savage (talkcontribs) 19:02, November 30, 2016 (UTC) - Please sign your comments with ~~~~

Glitched in China[edit source]

My sim is in China, doing the Dong Hou quest, he just entered the room that Dong Huo will appear in, with the door locking behind him but when he won the fight with the mummy he glitched out and reappeared on the top of the Dragon's Maw. I had to reset him to base camp, due to the steepness of the hill behind but now i can't get back in to finish the quest because the door is locked and the keystone to open it from the outside is already in place (i assume the door opens from the inside when you defeat Dong Huo or flick a switch but i can't get in to do it. Is there a cheat to open the door or a patch or something? i don't want to have to cancel the quest when i'm so close to finishing it :(

DenbiDenbi53 (talk) 18:59, January 17, 2017 (UTC)

Sim Won't Read Specific (skills) Book[edit source]

My sim needs to read Charisma 2 to advance, but everytime I give her the order to read the book, she picks it up, opens it to read it, then immediately puts it down without actullay reading it. She does not do this with any other books. Is there any way to fix this?

-A, June 05, 2017 —Preceding unsigned comment added by (talkcontribs) 23:03, June 5, 2017‎ (UTC) - Please sign your comments with ~~~~

Help[edit source]

My Sims wont sleep. The bed keeps throwing them out. When they go to nap or sleep, the automatically are thrown back on the floor. I have tried everything. (talk) 01:56, August 6, 2017 (UTC)Wanda

The Help desk may be better suited for the query. Nevertheless, we need to know the following in order to help you:
  1. What game are you playing? (e.g. The Sims 1, The Sims 2, etc.)
  2. What are some of your computer's specs? (e.g. "Windows 10 Version 1703, Acer Aspire V 15, 12 GB of RAM, 1 TB hard disk drive)
  3. Do you have any custom content installed? (e.g. Yes, I have the Overwatch mod installed)
k6ka 🍁 (Talk · Contributions) 02:08, August 6, 2017 (UTC)

On Sims Freeplay, there's a three screen glitch on my tablet, at one of my houses! When I tried to collect my Simoleons for planting Onions, get my Teen Idol hobby progress and reward for the Ice Sculpture hobby, it suddenly split into at least 3 screens! How do I fix this? I don't want to lose my progress, I'm on the Seniors Quest, and at level 30! Help me, please! (talk) 03:33, August 6, 2017 (UTC)

Sims 3 Fight Glitch?[edit source]

I've noticed a very annoying glitch with the "Fight!" interaction in The Sims 3. This can occur whenever a fight is initiated with another Sim, such as a Burglar or just a disliked Sim. If the fight is cancelled prematurely or overwritten by another interaction with "high priority" (such as police arriving to tackle the burglar, cancelling your Sims from fighting the burglar while they are fighting), Sims around the initiator of the fight will often completely stop what they are doing to run over then either point and laugh, cheer or act distressed (or scream angrily if Grumpy) at that Sim, long after the fight has finished (even if it has been weeks since the fight). They will sometimes repeat these actions over and over, until the glitch is fixed.

This glitch will last forever until the Sim is moved out of the household via Edit Town mode, and then shifted back into the house they where formerly in. This irritating glitch can even occur to child Sims having their fight cut off prematurely. Acherontia Styx (talk) 02:00, August 14, 2017 (UTC)

TS3 Glitch (PC and Console)[edit source]

So this is an extremely minor glitch but I want to bring it up because it should be at least noted on the glitches page. I know for a fact that it happens on both PC and PS3, and I am assuming it probably happens on Xbox 360 as well. Basically, picture this.You are at the central park in Moonlight Bay, and you see a guy named Cevin Faron. You decide to talk to him. So, you talk for a bit, learn that he's a Sous Chef, and then out of no where, in the place where it shows his name, it now says "Cevin is going home" As usual, all of the interactions are unusable, but the name has changed. It isn't permanent, and who knows, it might not even be a glitch at all, but it probably is. There aren't any websites mentioning it, either. ArceusDehEditor (talk) 05:58, November 4, 2017 (UTC)